El fallo fue descubierto por expertos de Facebook y afecta a dispositivos iOS y Android. Un archivo MP4, la llave para acceder a la información sensible del equipo

WhatsApp, la popular aplicación de mensajería con miles de usuarios en Argentina, tendría una vulnerabilidad crítica que pone en riesgo la información privada de quienes la utilizan.

Este fallo, denominado "Desbordamiento de la pila de búfer", fue descubierto por expertos de Facebook, la compañía propietaria de la app, y afecta a dispositivos con sistema operativo iOS y Android y la llave de entrada al equipo es un MP4 (video) contaminado.

Este archivo puede explotar el error en el programa de mensajería. ¿Cómo? Provocando que este no sea capaz de controlar adecuadamente la cantidad de datos que se copian y almacenan en la memoria diseñada para ello.

De esta manera, si la cantidad de información recibida supera la capacidad de guardado, los bytes sobrantes se guardan en zonas de memoria adyacentes, sobrescribiendo su contenido original.

ADEMÁS:

WhatsApp: cómo saber quién te tiene agendado

WhatsApp: ¿Cómo iniciar sesión en dos dispositivos al mismo tiempo?

“Un desbordamiento de búfer («stack-based buffer overflow») podría desencadenarse en WhatsApp enviando un archivo especialmente elaborado a un usuario de WhatsApp. Este asunto estuvo presente en el análisis de los metadatos elementales de un archivo MP4 y puede resultar en un ataque DoS o RCE”, explicaron desde la compañía de Mark Zuckerberg.

Esta vulnerabilidad es explotada por los cibercriminales para hacer un uso malintencionado de la misma.

Primero envían un video en formato MP4 y cuando el destinatario lo abre, el ciberdelincuente aprovecha la vulnerabilidad del desbordamiento de la pila de búfer para lanzar un ataque combinado DoS (sobrecarga de los sistemas de las víctimas) y RCE (hacer que el dispositivo de la víctima ejecute un código de manera remota para conseguir tener un completo acceso al equipo) para robar la información almacenada en WhatsApp.

Según informó Facebook desde un comunicado, esta vulnerabilidad ha afectado tanto a dispositivos iOS como Android en versiones antiguas de WhatsApp. Además se informa que el error fue parcheado con la actualización del pasado 3 de octubre.

Los usuarios que aún tengan las versiones de Android anteriores a 2.19.274, iOS previo a 2.19.100, versiones de Enterprise Client anteriores a 2.25.3, las de Windows Phone anteriores e incluyendo 2.18.368, las de Business para Android previas a 2.19.104, y las de Business para iOS anteriores a 2.19.100, aún están expuestos.

Por tal motivo se recomienda tener instalada la última versión de la app.

Contacto

Registro ISSN - Propiedad Intelectual: En trámite - Domicilio Legal: Intendente Beguiristain 146 - Sarandí (1872) - Buenos Aires - Argentina Teléfono/Fax: (+5411) 4204-3161/9513 - internet@dpopular.com.ar

Edición Nro. 15739

Dirección

Propietario: Man Press S.A. - Director: Francisco Nicolás Fascetto © 2017 Copyright Diario Popular - Todos los derechos reservados